CVE-2008-4226

NameCVE-2008-4226
DescriptionInteger overflow in the xmlSAX2Characters function in libxml2 2.7.2 allows context-dependent attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via a large XML document.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1666-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium-browser (PTS)jessie, jessie (lts)57.0.2987.98-1~deb8u1fixed
stretch (security), stretch (lts), stretch71.0.3578.80-1~deb9u1fixed
libxml2 (PTS)jessie, jessie (lts)2.9.1+dfsg1-5+deb8u14fixed
stretch (security)2.9.4+dfsg1-2.2+deb9u7fixed
stretch (lts), stretch2.9.4+dfsg1-2.2+deb9u9fixed
buster2.9.4+dfsg1-7+deb10u4fixed
buster (security)2.9.4+dfsg1-7+deb10u5fixed
bullseye (security), bullseye2.9.10+dfsg-6.7+deb11u3fixed
sid, bookworm2.9.14+dfsg-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromium-browsersource(unstable)5.0.375.29~r46008-1
libxml2sourceetch2.6.27.dfsg-6DSA-1666-1
libxml2source(unstable)2.6.32.dfsg-5

Search for package or bug name: Reporting problems