CVE-2011-5325

NameCVE-2011-5325
DescriptionDirectory traversal vulnerability in the BusyBox implementation of tar before 1.22.0 v5 allows remote attackers to point to files outside the current working directory via a symlink.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-1445-1, DLA-2559-1, ELA-20-1
Debian Bugs802702

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
busybox (PTS)jessie, jessie (lts)1:1.22.0-9+deb8u5fixed
stretch (security), stretch (lts), stretch1:1.22.0-19+deb9u2fixed
buster1:1.30.1-4fixed
bullseye1:1.30.1-6fixed
bookworm1:1.35.0-4fixed
trixie, sid1:1.36.1-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
busyboxsourcewheezy1:1.20.0-7+deb7u1ELA-20-1
busyboxsourcejessie1:1.22.0-9+deb8u2DLA-1445-1
busyboxsourcestretch1:1.22.0-19+deb9u1DLA-2559-1
busyboxsource(unstable)1:1.27.2-1802702

Notes

[wheezy] - busybox <no-dsa> (Minor issue)
[squeeze] - busybox <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems