CVE-2012-2668

NameCVE-2012-2668
Descriptionlibraries/libldap/tls_m.c in OpenLDAP, possibly 2.4.31 and earlier, when using the Mozilla NSS backend, always uses the default cipher suite even when TLSCipherSuite is set, which might cause OpenLDAP to use weaker ciphers than intended and make it easier for remote attackers to obtain sensitive information.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openldap (PTS)jessie, jessie (lts)2.4.40+dfsg-1+deb8u11fixed
stretch (security), stretch (lts), stretch2.4.44+dfsg-5+deb9u9fixed
buster, buster (security)2.4.47+dfsg-3+deb10u7fixed
bullseye (security), bullseye2.4.57+dfsg-3+deb11u1fixed
bookworm2.5.13+dfsg-3fixed
sid2.5.13+dfsg-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openldapsource(unstable)(not affected)

Notes

- openldap <not-affected> (OpenLDAP in Debian uses GNUTLS instead of Mozilla NSS)
https://bugzilla.redhat.com/show_bug.cgi?id=825875
http://www.openldap.org/its/index.cgi?findid=7285
http://www.openldap.org/devel/gitweb.cgi?p=openldap.git;a=commit;h=2c2bb2e

Search for package or bug name: Reporting problems