CVE-2012-3380

NameCVE-2012-3380
DescriptionDirectory traversal vulnerability in naxsi-ui/nx_extract.py in the Naxsi module before 0.46-1 for Nginx allows local users to read arbitrary files via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nginx (PTS)jessie, jessie (lts)1.6.2-5+deb8u10fixed
stretch (security)1.10.3-1+deb9u7fixed
stretch (lts), stretch1.10.3-1+deb9u8fixed
buster1.14.2-2+deb10u4fixed
buster (security)1.14.2-2+deb10u5fixed
bullseye (security), bullseye1.18.0-6.1+deb11u3fixed
bookworm1.22.1-9fixed
sid, trixie1.24.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nginxsourcesqueeze(not affected)
nginxsource(unstable)1.2.1-2

Notes

[squeeze] - nginx <not-affected> (naxsi package was introduced in 1.1.18-1)

Search for package or bug name: Reporting problems