CVE-2012-5127

NameCVE-2012-5127
DescriptionInteger overflow in Google Chrome before 23.0.1271.64 allows remote attackers to cause a denial of service (out-of-bounds read) or possibly have unspecified other impact via a crafted WebP image.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs704573

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium-browser (PTS)jessie, jessie (lts)57.0.2987.98-1~deb8u1fixed
stretch (security), stretch (lts), stretch71.0.3578.80-1~deb9u1fixed
libwebp (PTS)jessie, jessie (lts)0.4.1-1.2+deb8u1fixed
stretch (security)0.5.2-1+deb9u1fixed
stretch (lts), stretch0.5.2-1+deb9u3fixed
buster0.6.1-2+deb10u1fixed
buster (security)0.6.1-2+deb10u3fixed
bullseye (security), bullseye0.6.1-2.1+deb11u2fixed
bookworm (security), bookworm1.2.4-0.2+deb12u1fixed
trixie, sid1.3.2-0.4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromium-browsersourcesqueeze(unfixed)end-of-life
chromium-browsersource(unstable)24.0.1312.68-1
libwebpsource(unstable)0.1.3-3+nmu1704573

Notes

fixed in experimental version 0.2.1-1
https://bugs.gentoo.org/show_bug.cgi?id=442152
Upstream announce: https://groups.google.com/a/webmproject.org/forum/?fromgroups=#!topic/webp-discuss/QTtgi8YfgkE

Search for package or bug name: Reporting problems