CVE-2013-4549

NameCVE-2013-4549
DescriptionQXmlSimpleReader in Qt before 5.2 allows context-dependent attackers to cause a denial of service (memory consumption) via an XML Entity Expansion (XEE) attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs750141

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qt4-x11 (PTS)jessie, jessie (lts)4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u5fixed
stretch (security)4:4.8.7+dfsg-11+deb9u3fixed
stretch (lts), stretch4:4.8.7+dfsg-11+deb9u4fixed
buster4:4.8.7+dfsg-18+deb10u1fixed
buster (security)4:4.8.7+dfsg-18+deb10u2fixed
qtbase-opensource-src (PTS)jessie, jessie (lts)5.3.2+dfsg-4+deb8u6fixed
stretch (security)5.7.1+dfsg-3+deb9u3fixed
stretch (lts), stretch5.7.1+dfsg-3+deb9u4fixed
buster5.11.3+dfsg1-1+deb10u5fixed
buster (security)5.11.3+dfsg1-1+deb10u6fixed
bullseye5.15.2+dfsg-9+deb11u1fixed
bookworm5.15.8+dfsg-11+deb12u2fixed
trixie5.15.13+dfsg-2fixed
sid5.15.13+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qt4-x11source(unstable)4:4.8.5+git192-g085f851+dfsg-1low750141
qtbase-opensource-srcsource(unstable)5.1.1+dfsg-6

Notes

[wheezy] - qt4-x11 <no-dsa> (Minor issue)
[squeeze] - qt4-x11 <no-dsa> (Minor issue)
https://codereview.qt-project.org/#change,70708

Search for package or bug name: Reporting problems