CVE-2014-0133

NameCVE-2014-0133
DescriptionHeap-based buffer overflow in the SPDY implementation in nginx 1.3.15 before 1.4.7 and 1.5.x before 1.5.12 allows remote attackers to execute arbitrary code via a crafted request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs742059

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nginx (PTS)jessie, jessie (lts)1.6.2-5+deb8u10fixed
stretch (security)1.10.3-1+deb9u7fixed
stretch (lts), stretch1.10.3-1+deb9u8fixed
buster1.14.2-2+deb10u4fixed
buster (security)1.14.2-2+deb10u5fixed
bullseye (security), bullseye1.18.0-6.1+deb11u3fixed
bookworm1.22.1-9fixed
sid, trixie1.24.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nginxsourcesqueeze(not affected)
nginxsourcewheezy(not affected)
nginxsource(unstable)1.4.7-1unimportant742059

Notes

[wheezy] - nginx <not-affected> (Vulnerable code not present)
[squeeze] - nginx <not-affected> (Vulnerable code not present)
ngx_http_spdy_module introduced in 1.3.15
Debian compiles with --with-http_spdy_module, but also with --with-debug

Search for package or bug name: Reporting problems