CVE-2014-0203

NameCVE-2014-0203
DescriptionThe __do_follow_link function in fs/namei.c in the Linux kernel before 2.6.33 does not properly handle the last pathname component during use of certain filesystems, which allows local users to cause a denial of service (incorrect free operations and system crash) via an open system call.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-0015-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie, jessie (lts)3.16.84-1fixed
stretch (security)4.9.320-2fixed
stretch (lts), stretch4.9.320-3fixed
buster4.19.249-2fixed
buster (security)4.19.289-2fixed
bullseye5.10.197-1fixed
bullseye (security)5.10.191-1fixed
bookworm6.1.55-1fixed
bookworm (security)6.1.52-1fixed
trixie6.5.10-1fixed
sid6.5.13-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)2.6.33-1
linux-2.6sourcesqueeze2.6.32-48squeeze8
linux-2.6source(unstable)2.6.37-1

Notes

upstream fix: https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=86acdca1b63e6890540fa19495cfc708beff3d8b (v2.6.33)

Search for package or bug name: Reporting problems