CVE-2014-1490

NameCVE-2014-1490
DescriptionRace condition in libssl in Mozilla Network Security Services (NSS) before 3.15.4, as used in Mozilla Firefox before 27.0, Firefox ESR 24.x before 24.3, Thunderbird before 24.3, SeaMonkey before 2.24, and other products, allows remote attackers to cause a denial of service (use-after-free) or possibly have unspecified other impact via vectors involving a resumption handshake that triggers incorrect replacement of a session ticket.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-2858-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedove (PTS)jessie1:52.3.0-4~deb8u2fixed
nss (PTS)jessie, jessie (lts)2:3.26-1+debu8u18fixed
stretch (security)2:3.26.2-1.1+deb9u5fixed
stretch (lts), stretch2:3.26.2-1.1+deb9u7fixed
buster2:3.42.1-1+deb10u5fixed
buster (security)2:3.42.1-1+deb10u8fixed
bullseye (security), bullseye2:3.61-1+deb11u3fixed
bookworm2:3.87.1-1fixed
sid, trixie2:3.100-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icedovesourcesqueeze(unfixed)end-of-life
icedovesource(unstable)24.3.0-1
iceweaselsourcesqueeze(unfixed)end-of-life
iceweaselsourcewheezy24.3.0esr-1~deb7u1DSA-2858-1
iceweaselsource(unstable)24.3.0esr-1
nsssource(unstable)2:3.15.4-1

Notes

[squeeze] - nss <no-dsa> (Too complex to backport)
[wheezy] - nss <no-dsa> (complex to backport)
session tickets must be enabled by the client (mainly browsers)

Search for package or bug name: Reporting problems