CVE-2014-1693

NameCVE-2014-1693
DescriptionMultiple CRLF injection vulnerabilities in the FTP module in Erlang/OTP R15B03 allow context-dependent attackers to inject arbitrary FTP commands via CRLF sequences in the (1) user, (2) account, (3) cd, (4) ls, (5) nlist, (6) rename, (7) delete, (8) mkdir, (9) rmdir, (10) recv, (11) recv_bin, (12) recv_chunk_start, (13) send, (14) send_bin, (15) send_chunk_start, (16) append_chunk_start, (17) append, or (18) append_bin command.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs738132

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
erlang (PTS)jessie, jessie (lts)1:17.3-dfsg-4+deb8u2fixed
stretch (security)1:19.2.1+dfsg-2+deb9u1fixed
stretch (lts), stretch1:19.2.1+dfsg-2+really23.3.4.18-0+deb9u2fixed
buster1:21.2.6+dfsg-1fixed
buster (security)1:22.2.7+dfsg-1+deb10u1fixed
bullseye1:23.2.6+dfsg-1+deb11u1fixed
bookworm1:25.2.3+dfsg-1fixed
sid, trixie1:25.3.2.12+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
erlangsourcewheezy1:15.b.1-dfsg-4+deb7u1
erlangsource(unstable)1:16.b.3.1-dfsg-3low738132

Notes

[squeeze] - erlang <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems