CVE-2014-8767

NameCVE-2014-8767
DescriptionInteger underflow in the olsr_print function in tcpdump 3.9.6 through 4.6.2, when in verbose mode, allows remote attackers to cause a denial of service (crash) via a crafted length value in an OLSR frame.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-102-1, DSA-3086-1
Debian Bugs770434

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tcpdump (PTS)jessie, jessie (lts)4.9.3-1~deb8u2fixed
stretch (security), stretch (lts), stretch4.9.3-1~deb9u2fixed
buster4.9.3-1~deb10u2fixed
buster (security)4.9.3-1~deb10u1fixed
bullseye4.99.0-2+deb11u1fixed
bookworm4.99.3-1fixed
sid, trixie4.99.4-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tcpdumpsourcesqueeze4.1.1-1+deb6u1DLA-102-1
tcpdumpsourcewheezy4.3.0-1+deb7u1DSA-3086-1
tcpdumpsource(unstable)4.6.2-2770434

Notes

http://www.securityfocus.com/archive/1/534011/30/0/threaded

Search for package or bug name: Reporting problems