CVE-2014-8768

NameCVE-2014-8768
DescriptionMultiple Integer underflows in the geonet_print function in tcpdump 4.5.0 through 4.6.2, when in verbose mode, allow remote attackers to cause a denial of service (segmentation fault and crash) via a crafted length value in a Geonet frame.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs770415

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tcpdump (PTS)jessie, jessie (lts)4.9.3-1~deb8u2fixed
stretch (security), stretch (lts), stretch4.9.3-1~deb9u2fixed
buster4.9.3-1~deb10u2fixed
buster (security)4.9.3-1~deb10u1fixed
bullseye4.99.0-2+deb11u1fixed
bookworm4.99.3-1fixed
sid, trixie4.99.4-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tcpdumpsourcesqueeze(not affected)
tcpdumpsourcewheezy(not affected)
tcpdumpsource(unstable)4.6.2-2770415

Notes

[wheezy] - tcpdump <not-affected> (Vulnerable code added in 4.5.0)
[squeeze] - tcpdump <not-affected> (Vulnerable code added in 4.5.0)
http://www.securityfocus.com/archive/1/534010/30/0/threaded

Search for package or bug name: Reporting problems