CVE-2015-3414

NameCVE-2015-3414
DescriptionSQLite before 3.8.9 does not properly implement the dequoting of colla ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3252-1
Debian Bugs783968

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sqlite3 (PTS)jessie, jessie (lts)3.8.7.1-1+deb8u6fixed
stretch3.16.2-5+deb9u1fixed
stretch (security)3.16.2-5+deb9u3fixed
buster3.27.2-3+deb10u1fixed
bullseye3.34.0-1fixed
sid3.34.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sqlite3source(unstable)3.8.9-1783968
sqlite3sourcejessie3.8.7.1-1+deb8u1DSA-3252-1
sqlite3sourcesqueeze(not affected)
sqlite3sourcewheezy(not affected)

Notes

[wheezy] - sqlite3 <not-affected> (Can't reproduce the issue)
[squeeze] - sqlite3 <not-affected> (Can't reproduce the issue)
https://www.sqlite.org/src/info/eddc05e7bb31fae7
http://seclists.org/bugtraq/2015/Apr/97

Search for package or bug name: Reporting problems