CVE-2015-3456

NameCVE-2015-3456
DescriptionThe Floppy Disk Controller (FDC) in QEMU, as used in Xen 4.5.x and earlier and KVM, allows local guest users to cause a denial of service (out-of-bounds write and guest crash) or possibly execute arbitrary code via the (1) FD_CMD_READ_ID, (2) FD_CMD_DRIVE_SPECIFICATION_COMMAND, or other unspecified commands, aka VENOM.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-248-1, DLA-249-1, DLA-268-1, DSA-3259-1, DSA-3262-1, DSA-3274-1
Debian Bugs785424

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie, jessie (lts)1:2.1+dfsg-12+deb8u23fixed
stretch (security)1:2.8+dfsg-6+deb9u17fixed
stretch (lts), stretch1:2.8+dfsg-6+deb9u18fixed
buster1:3.1+dfsg-8+deb10u8fixed
buster (security)1:3.1+dfsg-8+deb10u11fixed
bullseye1:5.2+dfsg-11+deb11u3fixed
bullseye (security)1:5.2+dfsg-11+deb11u2fixed
bookworm1:7.2+dfsg-7+deb12u5fixed
sid, trixie1:8.2.1+ds-1fixed
virtualbox (PTS)jessie/contrib (lts), jessie/contrib4.3.36-dfsg-1+deb8u1fixed
sid/contrib7.0.14-dfsg-2fixed
xen (PTS)jessie, jessie (lts)4.4.4lts5-0+deb8u1fixed
stretch (security), stretch (lts), stretch4.8.5.final+shim4.10.4-1+deb9u12fixed
buster, buster (security)4.11.4+107-gef32c7afa2-1fixed
bullseye4.14.6-1fixed
bullseye (security)4.14.5+94-ge49571868d-1fixed
bookworm4.17.3+10-g091466ba55-1~deb12u1fixed
sid, trixie4.17.3+10-g091466ba55-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusourcesqueeze0.12.5+dfsg-3squeeze5DLA-248-1
qemusourcewheezy1.1.2+dfsg-6a+deb7u7
qemusourcejessie1:2.1+dfsg-12DSA-3259-1
qemusource(unstable)1:2.3+dfsg-3
qemu-kvmsourcesqueeze0.12.5+dfsg-5+squeeze12DLA-249-1
qemu-kvmsourcewheezy1.1.2+dfsg-6+deb7u7
qemu-kvmsource(unstable)(unfixed)
virtualboxsourcewheezy4.1.18-dfsg-2+deb7u5DSA-3274-1
virtualboxsourcejessie4.3.18-dfsg-3+deb8u2DSA-3274-1
virtualboxsource(unstable)4.3.28-dfsg-1785424
virtualbox-osesourcesqueeze3.2.10-dfsg-1+squeeze4DLA-268-1
virtualbox-osesource(unstable)(unfixed)
xensourcesqueeze(unfixed)end-of-life
xensourcewheezy4.1.4-3+deb7u6DSA-3262-1
xensource(unstable)4.4.0-1
xen-qemu-dm-4.0sourcesqueeze(unfixed)end-of-life
xen-qemu-dm-4.0source(unstable)(unfixed)

Notes

[squeeze] - xen <end-of-life> (Not supported in Squeeze LTS)
Xen switched to qemu-system in 4.4.0-1
http://xenbits.xen.org/xsa/advisory-133.html
[squeeze] - xen-qemu-dm-4.0 <end-of-life> (Not supported in Squeeze LTS)
http://www.oracle.com/technetwork/topics/security/alert-cve-2015-3456-2542656.html
http://venom.crowdstrike.com/

Search for package or bug name: Reporting problems