CVE-2015-4164

NameCVE-2015-4164
DescriptionThe compat_iret function in Xen 3.1 through 4.5 iterates the wrong way through a loop, which allows local 32-bit PV guest administrators to cause a denial of service (large loop and system hang) via a hypercall_iret call with EFLAGS.VM set.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-3286-1
Debian Bugs795721

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)jessie, jessie (lts)4.4.4lts5-0+deb8u1fixed
stretch (security), stretch (lts), stretch4.8.5.final+shim4.10.4-1+deb9u12fixed
buster, buster (security)4.11.4+107-gef32c7afa2-1fixed
bullseye4.14.6-1fixed
bullseye (security)4.14.5+94-ge49571868d-1fixed
bookworm4.17.3+10-g091466ba55-1~deb12u1fixed
sid, trixie4.17.3+10-g091466ba55-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensourcesqueeze(unfixed)end-of-life
xensourcewheezy4.1.4-3+deb7u8DSA-3286-1
xensourcejessie4.4.1-9+deb8u1DSA-3286-1
xensource(unstable)4.6.0-1795721

Notes

[squeeze] - xen <end-of-life> (Not supported in Squeeze LTS)
http://xenbits.xen.org/xsa/advisory-136.html

Search for package or bug name: Reporting problems