CVE-2016-1000107

NameCVE-2016-1000107
Descriptioninets in Erlang possibly 22.1 and earlier follows RFC 3875 section 4.1.18 and therefore does not protect applications from the presence of untrusted client data in the HTTP_PROXY environment variable, which might allow remote attackers to redirect an application's outbound HTTP traffic to an arbitrary proxy server via a crafted Proxy header in an HTTP request, aka an "httpoxy" issue.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
erlang (PTS)jessie, jessie (lts)1:17.3-dfsg-4+deb8u2vulnerable
stretch (security)1:19.2.1+dfsg-2+deb9u1vulnerable
stretch (lts), stretch1:19.2.1+dfsg-2+really23.3.4.18-0+deb9u2vulnerable
buster1:21.2.6+dfsg-1vulnerable
buster (security)1:22.2.7+dfsg-1+deb10u1vulnerable
bullseye1:23.2.6+dfsg-1+deb11u1vulnerable
bookworm1:25.2.3+dfsg-1vulnerable
sid, trixie1:25.3.2.12+dfsg-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
erlangsource(unstable)(unfixed)unimportant

Notes

https://bugs.erlang.org/browse/ERL-198
No part of Erlang does set HTTP_PROXY based on a Proxy: header, just hardening

Search for package or bug name: Reporting problems