CVE-2016-2198

NameCVE-2016-2198
DescriptionQEMU (aka Quick Emulator) built with the USB EHCI emulation support is vulnerable to a null pointer dereference flaw. It could occur when an application attempts to write to EHCI capabilities registers. A privileged user inside quest could use this flaw to crash the QEMU process instance resulting in DoS.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-1497-1
Debian Bugs813193

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie, jessie (lts)1:2.1+dfsg-12+deb8u23fixed
stretch (security)1:2.8+dfsg-6+deb9u17fixed
stretch (lts), stretch1:2.8+dfsg-6+deb9u19fixed
buster1:3.1+dfsg-8+deb10u8fixed
buster (security)1:3.1+dfsg-8+deb10u12fixed
bullseye1:5.2+dfsg-11+deb11u3fixed
bullseye (security)1:5.2+dfsg-11+deb11u2fixed
bookworm1:7.2+dfsg-7+deb12u6fixed
trixie1:8.2.4+ds-1fixed
sid1:9.0.2+ds-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusourcesqueeze(not affected)
qemusourcewheezy(not affected)
qemusourcejessie1:2.1+dfsg-12+deb8u7DLA-1497-1
qemusource(unstable)1:2.6+dfsg-1813193
qemu-kvmsource(unstable)(not affected)

Notes

[wheezy] - qemu <not-affected> (Introduced after v1.2.0)
[squeeze] - qemu <not-affected> (Introduced after v1.2.0)
- qemu-kvm <not-affected> (Introduced after v1.2.0)
Fixed by: http://git.qemu.org/?p=qemu.git;a=commit;h=dff0367cf66f489aa772320fa2937a8cac1ca30d (v2.6.0-rc0)
https://bugzilla.redhat.com/show_bug.cgi?id=1301643

Search for package or bug name: Reporting problems