CVE-2016-2800

NameCVE-2016-2800
DescriptionThe graphite2::Slot::getAttr function in Slot.cpp in Graphite 2 before 1.3.6, as used in Mozilla Firefox before 45.0 and Firefox ESR 38.x before 38.7, allows remote attackers to cause a denial of service (buffer over-read) or possibly have unspecified other impact via a crafted Graphite smart font, a different vulnerability than CVE-2016-2792.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-3510-1, DSA-3515-1, DSA-3520-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid120.0.1-1fixed
firefox-esr (PTS)jessie, jessie (lts)68.9.0esr-1~deb8u2fixed
stretch (security), stretch (lts), stretch91.11.0esr-1~deb9u1fixed
buster91.12.0esr-1~deb10u1fixed
buster (security)115.5.0esr-1~deb10u1fixed
bullseye102.15.0esr-1~deb11u1fixed
bullseye (security)115.5.0esr-1~deb11u1fixed
bookworm102.15.1esr-1~deb12u1fixed
bookworm (security)115.5.0esr-1~deb12u1fixed
sid, trixie115.5.0esr-1fixed
graphite2 (PTS)jessie, jessie (lts)1.3.10-1~deb8u1fixed
stretch1.3.10-1fixed
buster1.3.13-7fixed
sid, trixie, bullseye, bookworm1.3.14-1fixed
icedove (PTS)jessie1:52.3.0-4~deb8u2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)45.0-1
firefox-esrsource(unstable)45.0esr-1
graphite2sourcewheezy1.3.6-1~deb7u1DSA-3515-1
graphite2sourcejessie1.3.6-1~deb8u1DSA-3515-1
graphite2source(unstable)1.3.6-1
icedovesourcewheezy38.7.0-1~deb7u1DSA-3520-1
icedovesourcejessie38.7.0-1~deb8u1DSA-3520-1
icedovesource(unstable)38.7.0-1
iceweaselsourcewheezy38.7.0esr-1~deb7u1DSA-3510-1
iceweaselsourcejessie38.7.0esr-1~deb8u1DSA-3510-1
iceweaselsource(unstable)(unfixed)

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2016-37/

Search for package or bug name: Reporting problems