CVE-2016-2834

NameCVE-2016-2834
DescriptionMozilla Network Security Services (NSS) before 3.23, as used in Mozilla Firefox before 47.0, allows remote attackers to cause a denial of service (memory corruption and application crash) or possibly have unspecified other impact via unknown vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-527-1, DSA-3688-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid128.0-1fixed
firefox-esr (PTS)jessie, jessie (lts)68.9.0esr-1~deb8u2fixed
stretch (security), stretch (lts), stretch91.11.0esr-1~deb9u1fixed
buster91.12.0esr-1~deb10u1fixed
buster (security)115.12.0esr-1~deb10u1fixed
bullseye115.12.0esr-1~deb11u1fixed
bullseye (security)115.13.0esr-1~deb11u1fixed
bookworm115.12.0esr-1~deb12u1fixed
bookworm (security)115.13.0esr-1~deb12u1fixed
trixie115.12.0esr-1fixed
sid115.13.0esr-1fixed
nss (PTS)jessie, jessie (lts)2:3.26-1+debu8u18fixed
stretch (security)2:3.26.2-1.1+deb9u5fixed
stretch (lts), stretch2:3.26.2-1.1+deb9u7fixed
buster2:3.42.1-1+deb10u5fixed
buster (security)2:3.42.1-1+deb10u8fixed
bullseye (security), bullseye2:3.61-1+deb11u3fixed
bookworm2:3.87.1-1fixed
sid, trixie2:3.102-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)47.0-1
firefox-esrsource(unstable)(not affected)
nsssourcewheezy2:3.14.5-1+deb7u8DLA-527-1
nsssourcejessie2:3.26-1+debu8u1DSA-3688-1
nsssource(unstable)2:3.23-1

Notes

- firefox-esr <not-affected> (Doesn't apply to Firefox ESR)
https://www.mozilla.org/en-US/security/advisories/mfsa2016-61/

Search for package or bug name: Reporting problems