CVE-2016-4477

NameCVE-2016-4477
Descriptionwpa_supplicant 0.4.0 through 2.5 does not reject \n and \r characters in passphrase parameters, which allows local users to trigger arbitrary library loading and consequently gain privileges, or cause a denial of service (daemon outage), via a crafted (1) SET, (2) SET_CRED, or (3) SET_NETWORK command.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-473-1
Debian Bugs823411

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wpa (PTS)jessie, jessie (lts)2.3-1+deb8u13fixed
stretch (security), stretch (lts), stretch2:2.4-1+deb9u9fixed
buster2:2.7+git20190128+0c1e29f-6+deb10u3fixed
buster (security)2:2.7+git20190128+0c1e29f-6+deb10u4fixed
bullseye2:2.9.0-21fixed
bookworm2:2.10-12fixed
sid, trixie2:2.10-21fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wpasourcewheezy1.0-3+deb7u4DLA-473-1
wpasourcejessie2.3-1+deb8u4
wpasource(unstable)2.3-2.4823411

Notes

http://w1.fi/security/2016-1/

Search for package or bug name: Reporting problems