CVE-2016-6293

NameCVE-2016-6293
DescriptionThe uloc_acceptLanguageFromHTTP function in common/uloc.cpp in International Components for Unicode (ICU) through 57.1 for C/C++ does not ensure that there is a '\0' character at the end of a certain temporary array, which allows remote attackers to cause a denial of service (out-of-bounds read) or possibly have unspecified other impact via a call with a long httpAcceptLanguage argument.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-615-1, DSA-3725-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icu (PTS)jessie, jessie (lts)52.1-8+deb8u9fixed
stretch57.1-6+deb9u4fixed
stretch (security)57.1-6+deb9u5fixed
buster63.1-6+deb10u1fixed
buster (security)63.1-6+deb10u2fixed
sid, bookworm, bullseye67.1-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icusourcewheezy4.8.1.1-12+deb7u5DLA-615-1
icusourcejessie52.1-8+deb8u4DSA-3725-1
icusource(unstable)57.1-4

Notes

http://bugs.icu-project.org/trac/changeset/39109
http://bugs.icu-project.org/trac/ticket/12652
And possibly needs some more follow-up fixes, cf. with upstream changes
around/later than changeset 39109.

Search for package or bug name: Reporting problems