CVE-2016-7103

NameCVE-2016-7103
DescriptionCross-site scripting (XSS) vulnerability in jQuery UI before 1.12.0 might allow remote attackers to inject arbitrary web script or HTML via the closeText parameter of the dialog function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesELA-515-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jqueryui (PTS)jessie, jessie (lts)1.10.1+dfsg-1+deb8u1fixed
stretch1.12.1+dfsg-4fixed
buster1.12.1+dfsg-5fixed
bullseye1.12.1+dfsg-8+deb11u1fixed
sid, bookworm1.13.0+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jqueryuisourcejessie1.10.1+dfsg-1+deb8u1ELA-515-1
jqueryuisource(unstable)1.12.1+dfsg-1

Notes

[jessie] - jqueryui <no-dsa> (Minor issue)
[wheezy] - jqueryui <no-dsa> (Minor issue)
https://nodesecurity.io/advisories/127
https://github.com/jquery/jquery-ui/pull/1622
https://github.com/jquery/jquery-ui/pull/1632
https://github.com/jquery/api.jqueryui.com/issues/281

Search for package or bug name: Reporting problems