CVE-2016-7157

NameCVE-2016-7157
DescriptionThe (1) mptsas_config_manufacturing_1 and (2) mptsas_config_ioc_0 functions in hw/scsi/mptconfig.c in QEMU (aka Quick Emulator) allow local guest OS administrators to cause a denial of service (QEMU process crash) via vectors involving MPTSAS_CONFIG_PACK.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs837603

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie, jessie (lts)1:2.1+dfsg-12+deb8u23fixed
stretch (security)1:2.8+dfsg-6+deb9u17fixed
stretch (lts), stretch1:2.8+dfsg-6+deb9u19fixed
buster1:3.1+dfsg-8+deb10u8fixed
buster (security)1:3.1+dfsg-8+deb10u12fixed
bullseye1:5.2+dfsg-11+deb11u3fixed
bullseye (security)1:5.2+dfsg-11+deb11u2fixed
bookworm1:7.2+dfsg-7+deb12u6fixed
trixie1:8.2.4+ds-1fixed
sid1:9.0.2+ds-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusourcewheezy(not affected)
qemusourcejessie(not affected)
qemusource(unstable)1:2.6+dfsg-3.1837603
qemu-kvmsourcewheezy(not affected)
qemu-kvmsource(unstable)(unfixed)

Notes

[jessie] - qemu <not-affected> (Vulnerable code not present, introduced after v2.6)
[wheezy] - qemu <not-affected> (Vulnerable code not present, introduced after v2.6)
[wheezy] - qemu-kvm <not-affected> (Vulnerable code not present)
Upstream patches: https://lists.gnu.org/archive/html/qemu-devel/2016-08/msg04295.html
Upstream patches: https://lists.gnu.org/archive/html/qemu-devel/2016-08/msg04296.html
https://www.openwall.com/lists/oss-security/2016/09/06/4
Vulnerable code introduced after version 2.6: http://wiki.qemu.org/ChangeLog/2.6

Search for package or bug name: Reporting problems