CVE-2016-9817

NameCVE-2016-9817
DescriptionXen through 4.7.x allows local ARM guest OS users to cause a denial of service (host crash) via vectors involving a (1) data or (2) prefetch abort with the ESR_EL2.EA bit set.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)jessie, jessie (lts)4.4.4lts5-0+deb8u1vulnerable
stretch (security), stretch (lts), stretch4.8.5.final+shim4.10.4-1+deb9u12fixed
buster, buster (security)4.11.4+107-gef32c7afa2-1fixed
bullseye4.14.6-1fixed
bullseye (security)4.14.5+94-ge49571868d-1fixed
bookworm4.17.3+10-g091466ba55-1~deb12u1fixed
sid, trixie4.17.3+10-g091466ba55-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensourcewheezy(not affected)
xensource(unstable)4.8.0-1

Notes

[jessie] - xen <ignored> (Minor issue)
[wheezy] - xen <not-affected> (ARM support introduced in 4.4)
https://xenbits.xen.org/xsa/advisory-201.html
CVE for fix via patch https://xenbits.xen.org/xsa/xsa201-3.patch
or https://xenbits.xen.org/xsa/xsa201-3-4.7.patch

Search for package or bug name: Reporting problems