CVE-2017-10800

NameCVE-2017-10800
DescriptionWhen GraphicsMagick 1.3.25 processes a MATLAB image in coders/mat.c, i ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4321-1, ELA-277-1
Debian Bugs867060

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)jessie, jessie (lts)1.3.20-3+deb8u12fixed
stretch, stretch (security)1.3.30+hg15796-1~deb9u4fixed
buster, buster (security)1.4+really1.3.35-1~deb10u1fixed
sid, bullseye1.4+really1.3.36+hg16442-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksource(unstable)1.3.26-1867060
graphicsmagicksourcejessie1.3.20-3+deb8u12ELA-277-1
graphicsmagicksourcestretch1.3.30+hg15796-1~deb9u1DSA-4321-1

Notes

[jessie] - graphicsmagick <no-dsa> (Minor issue)
[wheezy] - graphicsmagick <no-dsa> (Minor issue)
http://hg.code.sf.net/p/graphicsmagick/code/rev/e5761e3a2012
The above commit unfortunately is not enough. There are more related
changes, and Bob Friesenhahn commented that it's not complete. All
the rlated changesets to mat.c since the one referenced should be
picked up.

Search for package or bug name: Reporting problems