CVE-2017-12424

NameCVE-2017-12424
DescriptionIn shadow before 4.5, the newusers tool could be made to manipulate internal data structures in ways unintended by the authors. Malformed input may lead to crashes (with a buffer overflow or other memory corruption) or other unspecified behaviors. This crosses a privilege boundary in, for example, certain web-hosting environments in which a Control Panel allows an unprivileged user account to create subaccounts.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2596-1, ELA-555-1
Debian Bugs756630

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
shadow (PTS)jessie, jessie (lts)1:4.2-3+deb8u5fixed
stretch (security), stretch (lts), stretch1:4.4-4.1+deb9u1fixed
buster1:4.5-1.1fixed
bullseye1:4.8.1-1fixed
sid, bookworm1:4.13+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
shadowsourcejessie1:4.2-3+deb8u5ELA-555-1
shadowsourcestretch1:4.4-4.1+deb9u1DLA-2596-1
shadowsource(unstable)1:4.5-1756630

Notes

[jessie] - shadow <no-dsa> (Minor issue)
[wheezy] - shadow <no-dsa> (Minor issue)
https://bugs.launchpad.net/ubuntu/+source/shadow/+bug/1266675
https://github.com/shadow-maint/shadow/commit/954e3d2e7113e9ac06632aee3c69b8d818cc8952 (4.5)

Search for package or bug name: Reporting problems