CVE-2017-14159

NameCVE-2017-14159
Descriptionslapd in OpenLDAP 2.4.45 and earlier creates a PID file after dropping privileges to a non-root account, which might allow local users to kill arbitrary processes by leveraging access to this non-root account for PID file modification before a root script executes a "kill `cat /pathname`" command, as demonstrated by openldap-initscript.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openldap (PTS)jessie, jessie (lts)2.4.40+dfsg-1+deb8u11vulnerable
stretch (security), stretch (lts), stretch2.4.44+dfsg-5+deb9u9vulnerable
buster, buster (security)2.4.47+dfsg-3+deb10u7vulnerable
bullseye (security), bullseye2.4.57+dfsg-3+deb11u1vulnerable
bookworm2.5.13+dfsg-3vulnerable
sid2.5.13+dfsg-4vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openldapsource(unstable)(unfixed)unimportant

Notes

http://www.openldap.org/its/index.cgi?findid=8703
Negligible security impact, but filed #877512

Search for package or bug name: Reporting problems