CVE-2017-15118

NameCVE-2017-15118
DescriptionA stack-based buffer overflow vulnerability was found in NBD server implementation in qemu before 2.11 allowing a client to request an export name of size up to 4096 bytes, which in fact should be limited to 256 bytes, causing an out-of-bounds stack write in the qemu process. If NBD server requires TLS, the attacker cannot trigger the buffer overflow without first successfully negotiating TLS.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs883406

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie, jessie (lts)1:2.1+dfsg-12+deb8u23fixed
stretch (security)1:2.8+dfsg-6+deb9u17fixed
stretch (lts), stretch1:2.8+dfsg-6+deb9u19fixed
buster1:3.1+dfsg-8+deb10u8fixed
buster (security)1:3.1+dfsg-8+deb10u12fixed
bullseye1:5.2+dfsg-11+deb11u3fixed
bullseye (security)1:5.2+dfsg-11+deb11u2fixed
bookworm1:7.2+dfsg-7+deb12u6fixed
trixie1:8.2.4+ds-1fixed
sid1:9.0.2+ds-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusourcewheezy(not affected)
qemusourcejessie(not affected)
qemusourcestretch(not affected)
qemusource(unstable)1:2.11+dfsg-1883406
qemu-kvmsource(unstable)(not affected)

Notes

[stretch] - qemu <not-affected> (Vulnerable code introduced in 2.10)
[jessie] - qemu <not-affected> (Vulnerable code introduced in 2.10)
[wheezy] - qemu <not-affected> (Vulnerable code introduced in 2.10)
- qemu-kvm <not-affected> (Vulnerable code introduced in 2.10)
Introduced by: https://git.qemu.org/?p=qemu.git;a=commit;h=f37708f6b8
https://lists.gnu.org/archive/html/qemu-devel/2017-11/msg05045.html

Search for package or bug name: Reporting problems