CVE-2017-15124

NameCVE-2017-15124
DescriptionVNC server implementation in Quick Emulator (QEMU) 2.11.0 and older was found to be vulnerable to an unbounded memory allocation issue, as it did not throttle the framebuffer updates sent to its client. If the client did not consume these updates, VNC server allocates growing memory to hold onto this data. A malicious remote VNC client could use this flaw to cause DoS to the server host.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-4213-1
Debian Bugs884806

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie, jessie (lts)1:2.1+dfsg-12+deb8u23vulnerable
stretch (security)1:2.8+dfsg-6+deb9u17fixed
stretch (lts), stretch1:2.8+dfsg-6+deb9u19fixed
buster1:3.1+dfsg-8+deb10u8fixed
buster (security)1:3.1+dfsg-8+deb10u12fixed
bullseye1:5.2+dfsg-11+deb11u3fixed
bullseye (security)1:5.2+dfsg-11+deb11u2fixed
bookworm1:7.2+dfsg-7+deb12u6fixed
trixie1:8.2.4+ds-1fixed
sid1:9.0.2+ds-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusourcestretch1:2.8+dfsg-6+deb9u4DSA-4213-1
qemusource(unstable)1:2.12~rc3+dfsg-1884806
qemu-kvmsource(unstable)(unfixed)

Notes

[jessie] - qemu <ignored> (invasive patch, also builds on 2.5 socket refactoring, tentative backport crashes, no other distro fix for 2.1)
[wheezy] - qemu <postponed> (Can be fixed along in later update)
[wheezy] - qemu-kvm <postponed> (Can be fixed along in later update)
https://www.openwall.com/lists/oss-security/2017/12/19/4
https://lists.gnu.org/archive/html/qemu-devel/2017-12/msg03705.html
https://lists.gnu.org/archive/html/qemu-devel/2018-02/msg00796.html

Search for package or bug name: Reporting problems