CVE-2017-15590

NameCVE-2017-15590
DescriptionAn issue was discovered in Xen through 4.9.x allowing x86 guest OS users to cause a denial of service (hypervisor crash) or possibly gain privileges because MSI mapping was mishandled.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-1549-1, DSA-4050-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)jessie, jessie (lts)4.4.4lts5-0+deb8u1fixed
stretch (security), stretch (lts), stretch4.8.5.final+shim4.10.4-1+deb9u12fixed
buster, buster (security)4.11.4+107-gef32c7afa2-1fixed
bullseye4.14.6-1fixed
bullseye (security)4.14.5+94-ge49571868d-1fixed
bookworm4.17.3+10-g091466ba55-1~deb12u1fixed
trixie4.17.3+10-g091466ba55-1fixed
sid4.17.3+10-g091466ba55-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensourcejessie4.4.4lts2-0+deb8u1DLA-1549-1
xensourcestretch4.8.2+xsa245-0+deb9u1DSA-4050-1
xensource(unstable)4.8.2+xsa245-0+deb9u1

Notes

[wheezy] - xen <no-dsa> (Patches too intrusive to backport)
https://xenbits.xen.org/xsa/advisory-237.html

Search for package or bug name: Reporting problems