CVE-2017-16909

NameCVE-2017-16909
DescriptionAn error related to the "LibRaw::panasonic_load_raw()" function (dcraw_common.cpp) in LibRaw versions prior to 0.18.6 can be exploited to cause a heap-based buffer overflow and subsequently cause a crash via a specially crafted TIFF image.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesELA-744-1, ELA-747-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libraw (PTS)jessie, jessie (lts)0.16.0-9+deb8u6fixed
stretch (security)0.17.2-6+deb9u2vulnerable
stretch (lts), stretch0.17.2-6+deb9u5fixed
buster0.19.2-2fixed
buster (security)0.19.2-2+deb10u4fixed
bullseye (security), bullseye0.20.2-1+deb11u1fixed
bookworm0.20.2-2.1fixed
trixie0.21.2-2fixed
sid0.21.2-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
librawsourcejessie0.16.0-9+deb8u5ELA-744-1
librawsourcestretch0.17.2-6+deb9u4ELA-747-1
librawsource(unstable)0.18.6-1

Notes

[wheezy] - libraw <no-dsa> (Minor issue)
https://secuniaresearch.flexerasoftware.com/secunia_research/2017-19
https://github.com/LibRaw/LibRaw/commit/f1394822a0152ceed77815eafa5cac4e8baab10a

Search for package or bug name: Reporting problems