CVE-2017-17740

NameCVE-2017-17740
Descriptioncontrib/slapd-modules/nops/nops.c in OpenLDAP through 2.4.45, when both the nops module and the memberof overlay are enabled, attempts to free a buffer that was allocated on the stack, which allows remote attackers to cause a denial of service (slapd crash) via a member MODDN operation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openldap (PTS)jessie, jessie (lts)2.4.40+dfsg-1+deb8u11vulnerable
stretch (security), stretch (lts), stretch2.4.44+dfsg-5+deb9u9vulnerable
buster, buster (security)2.4.47+dfsg-3+deb10u7vulnerable
bullseye (security), bullseye2.4.57+dfsg-3+deb11u1vulnerable
bookworm2.5.13+dfsg-3vulnerable
sid2.5.13+dfsg-4vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openldapsource(unstable)(unfixed)unimportant

Notes

http://www.openldap.org/its/index.cgi/Incoming?id=8759
nops slapd-module not built

Search for package or bug name: Reporting problems