CVE-2017-18206

NameCVE-2017-18206
DescriptionIn utils.c in zsh before 5.4, symlink expansion had a buffer overflow. ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1304-1, DLA-2470-1, ELA-316-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
zsh (PTS)jessie, jessie (lts)5.0.7-5+deb8u3fixed
stretch5.3.1-4vulnerable
stretch (security)5.3.1-4+deb9u4fixed
buster5.7.1-1fixed
sid, bullseye5.8-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zshsource(unstable)5.4.1-1
zshsourcejessie5.0.7-5+deb8u2ELA-316-1
zshsourcestretch5.3.1-4+deb9u1DLA-2470-1
zshsourcewheezy4.3.17-1+deb7u1DLA-1304-1

Notes

[jessie] - zsh <no-dsa> (Minor issue)
https://sourceforge.net/p/zsh/code/ci/c7a9cf465dd620ef48d586026944d9bd7a0d5d6d

Search for package or bug name: Reporting problems