CVE-2017-8872

NameCVE-2017-8872
DescriptionThe htmlParseTryOrFinish function in HTMLparser.c in libxml2 2.9.4 all ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2369-1, ELA-280-1
Debian Bugs862450

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxml2 (PTS)jessie, jessie (lts)2.9.1+dfsg1-5+deb8u9fixed
stretch2.9.4+dfsg1-2.2+deb9u2vulnerable
stretch (security)2.9.4+dfsg1-2.2+deb9u3fixed
buster2.9.4+dfsg1-7+deb10u1fixed
sid, bullseye2.9.10+dfsg-6.3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxml2source(unstable)2.9.4+dfsg1-6.1862450
libxml2sourcejessie2.9.1+dfsg1-5+deb8u9ELA-280-1
libxml2sourcestretch2.9.4+dfsg1-2.2+deb9u3DLA-2369-1

Notes

[jessie] - libxml2 <no-dsa> (Minor issue)
[wheezy] - libxml2 <no-dsa> (Minor issue)
https://bugzilla.gnome.org/show_bug.cgi?id=775200
https://gitlab.gnome.org/GNOME/libxml2/commit/123234f2cfcd9e9b9f83047eee1dc17b4c3f4407

Search for package or bug name: Reporting problems