CVE-2018-10061

NameCVE-2018-10061
DescriptionCacti before 1.1.37 has XSS because it makes certain htmlspecialchars calls without the ENT_QUOTES flag (these calls occur when the html_escape function in lib/html.php is not used).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2965-1, ELA-588-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cacti (PTS)jessie, jessie (lts)0.8.8b+dfsg-8+deb8u10fixed
stretch (security), stretch (lts), stretch0.8.8h+ds1-10+deb9u2fixed
buster1.2.2+ds1-2+deb10u4fixed
buster (security)1.2.2+ds1-2+deb10u2fixed
bullseye1.2.16+ds1-2fixed
bookworm, sid1.2.21+ds1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cactisourcejessie0.8.8b+dfsg-8+deb8u10ELA-588-1
cactisourcestretch0.8.8h+ds1-10+deb9u2DLA-2965-1
cactisource(unstable)1.1.37+ds1-1low

Notes

[jessie] - cacti <no-dsa> (Minor issue)
[wheezy] - cacti <no-dsa> (Minor issue)
https://github.com/Cacti/cacti/issues/1457
https://github.com/Cacti/cacti/commit/3ba47881c5f8f6a01606a5afd4f1934e32d97e92 (v1.1.37)
https://github.com/Cacti/cacti/commit/1f1b353b2e5ac9380cbea06dd9f6f8a20133379d (v1.1.37)
https://github.com/Cacti/cacti/commit/cb57a6e87751fbc6645bde1f8c16d9dca3765c4a (v1.1.37)
https://github.com/Cacti/cacti/commit/0730ce38735d146de098fc450c4420c1a3fbdf95 (v1.1.37)
https://github.com/Cacti/cacti/commit/0eb5a973c9b563b1f8c9e1d181baef06c0e89d56 (v1.1.37)
https://github.com/Cacti/cacti/commit/3a76892c178e27ce6e7189fd0ba17581f91154e8 (v1.1.37)

Search for package or bug name: Reporting problems