CVE-2018-1071

NameCVE-2018-1071
Descriptionzsh through version 5.4.2 is vulnerable to a stack-based buffer overfl ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1335-1, DLA-2470-1, ELA-316-1
Debian Bugs894044

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
zsh (PTS)jessie, jessie (lts)5.0.7-5+deb8u3fixed
stretch5.3.1-4vulnerable
stretch (security)5.3.1-4+deb9u4fixed
buster5.7.1-1fixed
sid, bullseye5.8-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zshsource(unstable)5.4.2-4low894044
zshsourcejessie5.0.7-5+deb8u2ELA-316-1
zshsourcestretch5.3.1-4+deb9u1DLA-2470-1
zshsourcewheezy4.3.17-1+deb7u2DLA-1335-1

Notes

[jessie] - zsh <no-dsa> (Minor issue)
https://sourceforge.net/p/zsh/code/ci/679b71ec4d852037fe5f73d35bf557b0f406c8d4
https://bugzilla.redhat.com/show_bug.cgi?id=1553531

Search for package or bug name: Reporting problems