CVE-2018-1100

NameCVE-2018-1100
Descriptionzsh through version 5.4.2 is vulnerable to a stack-based buffer overfl ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2470-1, ELA-316-1
Debian Bugs895225

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
zsh (PTS)jessie, jessie (lts)5.0.7-5+deb8u3fixed
stretch5.3.1-4vulnerable
stretch (security)5.3.1-4+deb9u4fixed
buster5.7.1-1fixed
sid, bullseye5.8-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zshsource(unstable)5.5-1895225
zshsourcejessie5.0.7-5+deb8u2ELA-316-1
zshsourcestretch5.3.1-4+deb9u1DLA-2470-1

Notes

[jessie] - zsh <no-dsa> (Minor issue)
[wheezy] - zsh <no-dsa> (Minor issue)
https://www.zsh.org/cgi-bin/mla/redirect?WORKERNUMBER=42607
https://sourceforge.net/p/zsh/code/ci/31f72205630687c1cef89347863aab355296a27f/

Search for package or bug name: Reporting problems