CVE-2018-12016

NameCVE-2018-12016
Descriptionlibephymain.so in GNOME Web (aka Epiphany) through 3.28.2.1 allows remote attackers to cause a denial of service (application crash) via certain window.open and document.write calls.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs901018

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
epiphany-browser (PTS)jessie3.14.1-1vulnerable
stretch3.22.7-1vulnerable
buster3.32.1.2-3~deb10u1fixed
buster (security)3.32.1.2-3~deb10u3fixed
bullseye (security), bullseye3.38.2-1+deb11u3fixed
bookworm43.1-1fixed
sid, trixie46~beta-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
epiphany-browsersource(unstable)3.28.3.1-1unimportant901018

Notes

webkit not covered by security support

Search for package or bug name: Reporting problems