CVE-2018-14464

NameCVE-2018-14464
DescriptionThe LMP parser in tcpdump before 4.9.3 has a buffer over-read in print-lmp.c:lmp_print_data_link_subobjs().
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-1955-1, DSA-4547-1, ELA-174-1
Debian Bugs941698

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tcpdump (PTS)jessie, jessie (lts)4.9.3-1~deb8u2fixed
stretch (security), stretch (lts), stretch4.9.3-1~deb9u2fixed
buster4.9.3-1~deb10u2fixed
buster (security)4.9.3-1~deb10u1fixed
bullseye4.99.0-2+deb11u1fixed
bookworm4.99.3-1fixed
trixie, sid4.99.4-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tcpdumpsourcewheezy4.9.3-1~deb7u1ELA-174-1
tcpdumpsourcejessie4.9.3-1~deb8u1DLA-1955-1
tcpdumpsourcestretch4.9.3-1~deb9u1DSA-4547-1
tcpdumpsourcebuster4.9.3-1~deb10u1DSA-4547-1
tcpdumpsource(unstable)4.9.3-1941698

Notes

https://github.com/the-tcpdump-group/tcpdump/commit/d97e94223720684c6aa740ff219e0d19426c2220

Search for package or bug name: Reporting problems