CVE-2018-14599

NameCVE-2018-14599
DescriptionAn issue was discovered in libX11 through 1.6.5. The function XListExtensions in ListExt.c is vulnerable to an off-by-one error caused by malicious server responses, leading to DoS or possibly unspecified other impact.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-1482-1, ELA-30-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libx11 (PTS)jessie, jessie (lts)2:1.6.2-3+deb8u7fixed
stretch (security)2:1.6.4-3+deb9u4fixed
stretch (lts), stretch2:1.6.4-3+deb9u6fixed
buster2:1.6.7-1+deb10u2fixed
buster (security)2:1.6.7-1+deb10u4fixed
bullseye (security), bullseye2:1.7.2-1+deb11u2fixed
bookworm (security), bookworm2:1.8.4-2+deb12u2fixed
trixie, sid2:1.8.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libx11sourcewheezy2:1.5.0-1+deb7u5ELA-30-1
libx11sourcejessie2:1.6.2-3+deb8u2DLA-1482-1
libx11sourcestretch2:1.6.4-3+deb9u1
libx11source(unstable)2:1.6.6-1low

Notes

[wheezy] - libx11 <no-dsa> (Minor issue)
https://gitlab.freedesktop.org/xorg/lib/libx11/commit/b469da1430cdcee06e31c6251b83aede072a1ff0

Search for package or bug name: Reporting problems