CVE-2018-15518

NameCVE-2018-15518
DescriptionQXmlStream in Qt 5.x before 5.11.3 has a double-free or corruption during parsing of a specially crafted illegal XML document.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-1627-1, DLA-1786-1, DLA-2377-1, DSA-4374-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qt4-x11 (PTS)jessie, jessie (lts)4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u5fixed
stretch (security)4:4.8.7+dfsg-11+deb9u3fixed
stretch (lts), stretch4:4.8.7+dfsg-11+deb9u4fixed
buster4:4.8.7+dfsg-18+deb10u1fixed
buster (security)4:4.8.7+dfsg-18+deb10u2fixed
qtbase-opensource-src (PTS)jessie, jessie (lts)5.3.2+dfsg-4+deb8u6fixed
stretch (security)5.7.1+dfsg-3+deb9u3fixed
stretch (lts), stretch5.7.1+dfsg-3+deb9u4fixed
buster5.11.3+dfsg1-1+deb10u5fixed
buster (security)5.11.3+dfsg1-1+deb10u6fixed
bullseye5.15.2+dfsg-9+deb11u1fixed
bookworm5.15.8+dfsg-11+deb12u2fixed
trixie5.15.13+dfsg-2fixed
sid5.15.13+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qt4-x11sourcewheezy(unfixed)end-of-life
qt4-x11sourcejessie4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u2DLA-1786-1
qt4-x11sourcestretch4:4.8.7+dfsg-11+deb9u1DLA-2377-1
qt4-x11source(unstable)4:4.8.7+dfsg-18low
qtbase-opensource-srcsourceexperimental5.11.3+dfsg-1
qtbase-opensource-srcsourcewheezy(unfixed)end-of-life
qtbase-opensource-srcsourcejessie5.3.2+dfsg-4+deb8u3DLA-1627-1
qtbase-opensource-srcsourcestretch5.7.1+dfsg-3+deb9u1DSA-4374-1
qtbase-opensource-srcsource(unstable)5.11.3+dfsg-2

Notes

https://blog.qt.io/blog/2018/12/04/qt-5-11-3-released-important-security-updates/
https://codereview.qt-project.org/#/c/236691/

Search for package or bug name: Reporting problems