CVE-2018-16883

NameCVE-2018-16883
Descriptionsssd versions from 1.13.0 to before 2.0.0 did not properly restrict access to the infopipe according to the "allowed_uids" configuration parameter. If sensitive information were stored in the user directory, this could be inadvertently disclosed to local attackers.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow
Debian Bugs916824

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sssd (PTS)jessie, jessie (lts)1.11.7-3+deb8u2fixed
stretch1.15.0-3+deb9u1vulnerable
stretch (security)1.15.0-3+deb9u2vulnerable
buster1.16.3-3.2vulnerable
bullseye2.4.1-2fixed
sid, bookworm2.6.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sssdsourcewheezy(unfixed)end-of-life
sssdsourcejessie(not affected)
sssdsource(unstable)2.2.0-1916824

Notes

[buster] - sssd <no-dsa> (Minor issue)
[stretch] - sssd <no-dsa> (Minor issue)
[jessie] - sssd <not-affected> (Issue got introduced with 1.13.0)
https://bugzilla.redhat.com/show_bug.cgi?id=1659862
Fixed in upstream 2.0.0 while refactoring code
Fixed by https://pagure.io/SSSD/sssd/c/fbe2476a3dd9be83ffa85c29dca26f734618d72d?branch=master

Search for package or bug name: Reporting problems