CVE-2018-18928

NameCVE-2018-18928
DescriptionInternational Components for Unicode (ICU) for C/C++ 63.1 has an integer overflow in number::impl::DecimalQuantity::toScientificString() in i18n/number_decimalquantity.cpp.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icu (PTS)jessie, jessie (lts)52.1-8+deb8u9fixed
stretch57.1-6+deb9u4fixed
stretch (security)57.1-6+deb9u5fixed
buster63.1-6+deb10u1fixed
buster (security)63.1-6+deb10u2fixed
sid, bookworm, bullseye67.1-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icusourcewheezy(not affected)
icusourcejessie(not affected)
icusourcestretch(not affected)
icusource(unstable)63.1-3

Notes

[stretch] - icu <not-affected> (Vulnerable code not present)
[jessie] - icu <not-affected> (Vulnerable code not present)
https://bugs.chromium.org/p/chromium/issues/detail?id=900059
Fixed by: https://github.com/unicode-org/icu/commit/53d8c8f3d181d87a6aa925b449b51c4a2c922a51
https://unicode-org.atlassian.net/browse/ICU-20246
[wheezy] - icu <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems