CVE-2018-19132

NameCVE-2018-19132
DescriptionSquid before 4.4, when SNMP is enabled, allows a denial of service (Me ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1596-1, DLA-2278-1, ELA-271-1
Debian Bugs912294

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid (PTS)buster, buster (security)4.6-1+deb10u4fixed
sid, bullseye4.13-1fixed
squid3 (PTS)jessie, jessie (lts)3.5.23-5+deb8u2fixed
stretch3.5.23-5+deb9u1vulnerable
stretch (security)3.5.23-5+deb9u5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squidsource(unstable)4.4-1low912294
squidsourcewheezy(unfixed)end-of-life
squid3source(unstable)(unfixed)low
squid3sourcejessie3.5.23-5+deb8u1ELA-271-1
squid3sourcestretch3.5.23-5+deb9u2DLA-2278-1
squid3sourcewheezy(unfixed)end-of-life

Notes

http://www.squid-cache.org/Advisories/SQUID-2018_5.txt
3.5: http://www.squid-cache.org/Versions/v3/3.5/changesets/squid-3.5-bc9786119f058a76ddf0625424bc33d36460b9a2.patch
4.x: http://www.squid-cache.org/Versions/v4/changesets/squid-4-983c5c36e5f109512ed1af38a329d0b5d0967498.patch

Search for package or bug name: Reporting problems