CVE-2018-20506

NameCVE-2018-20506
DescriptionSQLite before 3.25.3, when the FTS3 extension is enabled, encounters a ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1613-1, DLA-2340-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sqlite3 (PTS)jessie, jessie (lts)3.8.7.1-1+deb8u6fixed
stretch3.16.2-5+deb9u1vulnerable
stretch (security)3.16.2-5+deb9u3fixed
buster3.27.2-3+deb10u1fixed
sid, bullseye3.34.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sqlite3source(unstable)3.25.3-1
sqlite3sourcejessie3.8.7.1-1+deb8u3DLA-1613-1
sqlite3sourcestretch3.16.2-5+deb9u2DLA-2340-1

Notes

https://sqlite.org/src/info/940f2adc8541a838
[wheezy] - sqlite3 <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems