CVE-2018-20843

NameCVE-2018-20843
DescriptionIn libexpat in Expat before 2.2.7, XML input including XML names that contain a large number of colons could make the XML parser consume a high amount of RAM and CPU resources while processing (enough to be usable for denial-of-service attacks).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1839-1, DSA-4472-1, ELA-136-1
Debian Bugs931031

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
expat (PTS)jessie, jessie (lts)2.1.0-6+deb8u10fixed
stretch (security)2.2.0-2+deb9u5fixed
stretch (lts), stretch2.2.0-2+deb9u7fixed
buster2.2.6-2+deb10u4fixed
buster (security)2.2.6-2+deb10u6fixed
bullseye (security), bullseye2.2.10-2+deb11u5fixed
sid, bookworm2.5.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
expatsourcewheezy2.1.0-1+deb7u6ELA-136-1
expatsourcejessie2.1.0-6+deb8u5DLA-1839-1
expatsourcestretch2.2.0-2+deb9u2DSA-4472-1
expatsource(unstable)2.2.6-2931031

Notes

https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=5226
https://github.com/libexpat/libexpat/issues/186
https://github.com/libexpat/libexpat/pull/262
https://github.com/libexpat/libexpat/commit/11f8838bf99ea0a6f0b76f9760c43704d00c4ff6

Search for package or bug name: Reporting problems