CVE-2018-5147

NameCVE-2018-5147
DescriptionThe libtremor library has the same flaw as CVE-2018-5146. This library is used by Firefox in place of libvorbis on Android and ARM platforms. This vulnerability affects Firefox ESR < 52.7.2 and Firefox < 59.0.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-1312-1, DLA-1319-1, DSA-4141-1, DSA-4143-1
Debian Bugs893132

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid126.0-1fixed
firefox-esr (PTS)jessie, jessie (lts)68.9.0esr-1~deb8u2fixed
stretch (security), stretch (lts), stretch91.11.0esr-1~deb9u1fixed
buster91.12.0esr-1~deb10u1fixed
buster (security)115.11.0esr-1~deb10u1fixed
bullseye115.7.0esr-1~deb11u1fixed
bullseye (security)115.11.0esr-1~deb11u1fixed
bookworm115.7.0esr-1~deb12u1fixed
bookworm (security)115.11.0esr-1~deb12u1fixed
sid, trixie115.11.0esr-1fixed
libvorbisidec (PTS)jessie, jessie (lts)1.0.2+svn18153-1~deb8u2fixed
stretch (security), stretch (lts), stretch1.0.2+svn18153-1+deb9u1fixed
buster1.2.1+git20180316-3fixed
sid, trixie, bullseye, bookworm1.2.1+git20180316-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)59.0.1-1
firefox-esrsourcewheezy52.7.2esr-1~deb7u1DLA-1319-1
firefox-esrsourcejessie52.7.2esr-1~deb8u1DSA-4143-1
firefox-esrsourcestretch52.7.2esr-1~deb9u1DSA-4143-1
firefox-esrsource(unstable)52.7.2esr-1
libvorbisidecsourcewheezy1.0.2+svn18153-0.2+deb7u1DLA-1312-1
libvorbisidecsourcejessie1.0.2+svn18153-1~deb8u2DSA-4141-1
libvorbisidecsourcestretch1.0.2+svn18153-1+deb9u1DSA-4141-1
libvorbisidecsource(unstable)1.2.1+git20180316-1893132

Notes

https://git.xiph.org/?p=tremor.git;a=commit;h=562307a4a7082e24553f3d2c55dab397a17c4b4f
https://www.mozilla.org/en-US/security/advisories/mfsa2018-08/

Search for package or bug name: Reporting problems