CVE-2019-10064

NameCVE-2019-10064
Descriptionhostapd before 2.6, in EAP mode, makes calls to the rand() and random() standard library functions without any preceding srand() or srandom() call, which results in inappropriate use of deterministic values. This was fixed in conjunction with CVE-2016-10743.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2138-1, DLA-2318-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wpa (PTS)jessie, jessie (lts)2.3-1+deb8u13fixed
stretch (security), stretch (lts), stretch2:2.4-1+deb9u9fixed
buster2:2.7+git20190128+0c1e29f-6+deb10u3fixed
buster (security)2:2.7+git20190128+0c1e29f-6+deb10u4fixed
bullseye2:2.9.0-21fixed
bookworm2:2.10-12fixed
sid, trixie2:2.10-21fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wpasourcewheezy(unfixed)end-of-life
wpasourcejessie2.3-1+deb8u10DLA-2138-1
wpasourcestretch2:2.4-1+deb9u7DLA-2318-1
wpasource(unstable)2:2.6-7

Notes

https://www.openwall.com/lists/oss-security/2020/02/27/1
Comment from upstream: https://www.openwall.com/lists/oss-security/2020/02/27/2
Issue fixed in conjunction with CVE-2016-10743.
https://w1.fi/cgit/hostap/commit/?id=4b16c15bbc8b20a85bb3d6f45bba5621a047618e
There was already a 2.6 upload late in 2016 but then reverted to a 2.4 based
version and only reuploaded as 2:2.6-7 to unstable.

Search for package or bug name: Reporting problems