CVE-2019-1010319

NameCVE-2019-1010319
DescriptionWavPack 5.1.0 and earlier is affected by: CWE-457: Use of Uninitialize ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2525-1, ELA-346-1
Debian Bugs932061

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wavpack (PTS)jessie, jessie (lts)4.70.0-1+deb8u1fixed
stretch5.0.0-2+deb9u2vulnerable
stretch (security)5.0.0-2+deb9u3fixed
buster5.1.0-6vulnerable
sid, bullseye5.4.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wavpacksourcewheezy(unfixed)end-of-life
wavpacksourcejessie4.70.0-1+deb8u1ELA-346-1
wavpacksourcestretch5.0.0-2+deb9u3DLA-2525-1
wavpacksource(unstable)5.1.0-7low932061

Notes

[buster] - wavpack <no-dsa> (Minor issue)
https://github.com/dbry/WavPack/commit/33a0025d1d63ccd05d9dbaa6923d52b1446a62fe
https://github.com/dbry/WavPack/issues/68

Search for package or bug name: Reporting problems