CVE-2019-12854

NameCVE-2019-12854
DescriptionDue to incorrect string termination, Squid cachemgr.cgi 4.0 through 4.7 may access unallocated memory. On systems with memory access protections, this can cause the CGI process to terminate unexpectedly, resulting in a denial of service for all clients using it.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-4507-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid (PTS)buster4.6-1+deb10u7fixed
buster (security)4.6-1+deb10u10fixed
bullseye (security), bullseye4.13-10+deb11u2fixed
bookworm5.7-2fixed
trixie6.6-1fixed
sid6.8-1fixed
squid3 (PTS)jessie, jessie (lts)3.5.23-5+deb8u7fixed
stretch (security)3.5.23-5+deb9u7fixed
stretch (lts), stretch3.5.23-5+deb9u10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squidsourcewheezy(unfixed)end-of-life
squidsourcebuster4.6-1+deb10u1DSA-4507-1
squidsource(unstable)4.8-1
squid3source(unstable)(not affected)

Notes

- squid3 <not-affected> (Vulnerable code not present; Vulnerable code only in 4.x series)
http://www.squid-cache.org/Advisories/SQUID-2019_1.txt
http://www.squid-cache.org/Versions/v4/changesets/squid-4-2981a957716c61ff7e21eee1d7d6eb5a237e466d.patch

Search for package or bug name: Reporting problems